誰かが同じようなことを言っていたけど、checkという単語を関数名とかに使うのはやめるべき。

  1. 戻り値が分からない
  2. チェックして不正だった場合の処理が分からない


1の戻り値が真偽値ならJavaとかならisとかcanとかhasで始まるし
Lisp系ならpで終わるしScheme系なら?で終わるのが好ましい。
それ以外の戻り値なら他の関数名を考えるべき。


2の処理が「エラーを吐いて異常終了する」という処理なら自分はvalidateを使う。
それ以外なら考え直すべき。


と僕は思います。



追記:
> id:mattn (はてブ)
validateは僕も大体voidです。
異常終了するなら返り値いりませんし。