Subsonicのためにlameをインストールする

折角Subsonicインストールしたしlameとかffmpegとかもインストールしておく。
lameとかインストールしとくとトランスコーディング機能が使えるようになるらしい。

回線が細いときは、トランスコーディング機能で逐一ビットレートを落として再生とかも出来ますよ。設定画面で色々と探ると結構なんでも出来ます。

さくらのVPSとSubsonicでiTunesをゴミ箱にダンクシュートした - 甘味志向@はてな

Debianだとnon-freeなリポジトリに含まれてるのでリポジトリを追加して証明書をインストールする。
証明書の追加は MultimediaCodecs - Debian Wiki みたらdebでインストールできるらしい。

リポジトリの追加

/etc/apt/sources.list.d/debian-multimedia.listを作成して
MultimediaCodecs - Debian Wiki にあった以下のリストを参考にstableだけ追加。
stableだけ追加しとけばいいんだけどなんとなく元のリストも残しておく。

deb http://www.debian-multimedia.org lenny main non-free
deb http://www.debian-multimedia.org squeeze main non-free
deb http://www.debian-multimedia.org wheezy main non-free
deb http://www.debian-multimedia.org sid main non-free
deb http://www.debian-multimedia.org experimental main

MultimediaCodecs - Debian Wiki
# for lame (used by Subsonic as transcoder)
deb http://www.debian-multimedia.org stable main non-free
#deb http://www.debian-multimedia.org lenny main non-free
#deb http://www.debian-multimedia.org squeeze main non-free
#deb http://www.debian-multimedia.org wheezy main non-free
#deb http://www.debian-multimedia.org sid main non-free
#deb http://www.debian-multimedia.org experimental main

うまくいってるみたい?

$ sudo apt-get update
Get:1 http://www.debian-multimedia.org stable Release.gpg
Ign http://www.debian-multimedia.org/ stable/main Translation-en
Ign http://www.debian-multimedia.org/ stable/main Translation-en_US
Ign http://www.debian-multimedia.org/ stable/non-free Translation-en
Ign http://www.debian-multimedia.org/ stable/non-free Translation-en_US
Get:2 http://www.debian-multimedia.org stable Release
Get:3 http://www.debian-multimedia.org stable/main amd64 Packages
Get:4 http://www.debian-multimedia.org stable/non-free amd64 Packages

証明書の追加

$ sudo wget http://debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb
$ sudo dpkg -i debian-multimedia-keyring_2010.12.26_all.deb

lameとかインストール

$ sudo apt-get update; sudo apt-get install lame flac faad vorbis-tools ffmpeg

冒頭で言ったようにdebをインストールしたりリポジトリを追加したりしてないとlameってパッケージはないって言われる。
このインストールするパッケージはどこソースだか忘れた。