m2eclipse 1.5.0にはEclipse 4.4(Luna)が必要

m2e-aptが入れられなくてエラーメッセージ見てみたら、Eclipseのバージョンが古くてm2eが1.4.0までしか入らなかったせいだったらしい。
Eclipse 4.4にしたら無事m2eとm2e-aptが入って解決した。

操作の詳細
1 つ以上の必須項目が見つからないため、インストールを完了できません。
Software being installed: Maven Integration for Eclipse JDT APT 1.1.0.201405210909 (org.jboss.tools.maven.apt.feature.feature.group 1.1.0.201405210909)
Missing requirement: Maven Integration for Eclipse JDT APT Core 1.1.0.201405210909 (org.jboss.tools.maven.apt.core 1.1.0.201405210909) requires 'bundle org.eclipse.m2e.core 1.5.0' but it could not be found
Cannot satisfy dependency:
From: Maven Integration for Eclipse JDT APT 1.1.0.201405210909 (org.jboss.tools.maven.apt.feature.feature.group 1.1.0.201405210909)
To: org.jboss.tools.maven.apt.core [1.1.0.201405210909]